• Vergroot lettergrootte
  • Standaard lettergrootte
  • Verklein lettergrootte
Home Losse flodders Excel-truc: zoeken of waarde voorkomt in een cel
Excel-truc: zoeken of waarde voorkomt in een cel

excel excel-truc truc

Controleren of een cel (A1) een specifieke waarde ("BK") bevat.

=ALS(ISGETAL(ZOEK("BK";A1));"bevat BK";"geen BK")

 

Je kunt ook controleren of een waarde voorkomt in een specifiek bereik.

Hiervoor kun je de VERT.ZOEKEN-formule gebruiken.

In het onderstaande voorbeeld wordt voor de waarde in cel A6 gecontroleerd of deze voorkomt in een tabel (A$2:A$1112) in een ander werkblad (met als naam: '1113')

Het resulteert in een "Ja" als de waarde voorkomt in het gespecificeerde bereik, en "Nee" als dit niet het geval is.

=ALS(VERT.ZOEKEN(A6;'1113'!A$2:A$1112;1)=A6;"Ja";"Nee")

 

VERT.ZOEKEN verwacht vier parameters:

  1. De waarde die ik ga opzoeken, in dit geval de eerste vier karakters van de postcode bij een bestelling: LINKS(A2; 4). (A2 uiteraard voor de eerste bestelling, A3 voor de tweede, et cetera.)
  2. Het kolombereik met daarin de kolom waarin ik de postcode ga opzoeken en de kolom met de steden, de eerste twee kolommen van het werkblad Postcodes dus: Postcodes!A:B
  3. Het kolomnummer in het bereik met het resultaat, in dit geval is dat de tweede kolom: 2.
  4. En of de waarde exact of niet-geheel exact moet overkomen. Dit laatste houdt in dat als er niets wordt gevonden, er een resultaat uit een bijna overeenkomende cel wordt teruggegeven. Dat is vrijwel nooit nodig, dus vullen we hier ONWAAR in.

 

Laatst aangepast op zondag, 17 maart 2019 20:26  

Simplicity means the achievement of maximum effect with minimum means.

Koichi Kawana

Banner
Banner

Archief

Lean boeken top 5

(maart 2016)
Banner
Banner
Banner
Banner
Banner

We hebben 262 gasten online
Artikelen

standaarden taiichi ohno lean

Banner


Brown paper methode wessel berkman

De Brown Paper-methode
De leukste veranderaanpak met de hoogste resultaten
Wessel Berkman, Marcel van der Schaaff

Bij Bol.com | Managementboek

Lean boekentips

Dagstarts en Hoshin Kanri
Continu Leren en Verbeteren in de juiste richting met Dagstarts en Hoshin Kanri
Bert Teeuwen

Bij Bol.com | Managementboek

Banner